Subs Cut in and Out - Car Audio Forumz - The #1 Car Audio Forum

Car Audio Technical Discussions Dedicated to the technical side of Car Audio.

Subs Cut in and Out

Reply

 
 
 
Old 04-10-2018, 02:32 AM
  #1  
0 Watt CAFz'r
Thread Starter
 
Join Date: Apr 2018
Posts: 1
Subs Cut in and Out

Hey everyone! New to this forum so I totally apologize if this is not where this is supposed to be! But going to try to make a long story short.

So, sometimes whenever I start my truck Iíll hear a loud flicker almost like a spark and my truck will ding for a second and say check system. And then goes back to normal, during that flicker my subs will make a weird noise as well. Sometimes when I hitting hard on my subs, theyíll cut in and out or itíll make that flicker noise. One time I went to my truck to start it and it wouldnít start. I checked the cables and wiring and moved it at the battery at the positive terminal it sparked and went back to my truck and it started. My subs or amp are not getting to hot or being over powered. Iíve felt them after slamming them for 15 minutes and theyíre fine. I donít think itís an over power issue but Iím at a complete loss of words. I just got my system install maybe 2 weeks ago. A little about my system. Iím running 2 JL Audio 12ís TW3ís. On a Kenwood 1000 watt amp. Iím unsure what itís wired to as I did not do it and havenít checked. I have a stock radio hooked up to the JCL2 radio converter I believe? Iím not around my truck right now to check. But Iím scared that Iím hurting the subs every time they flicker and turn off for a second, and I donít want to be our 700$... is it possible itís a ground issue? Iím going to call the company who installed them if it continues, any advice would be much appreciated!!!!
Firefighter967 is offline  
Reply With Quote
Old 04-13-2018, 11:57 PM
  #2  
50 Watt CAFz'r
 
Join Date: Nov 2017
Posts: 54
Yeah sound like a power or ground problem at the vehicles battery cables. The terminals have to be clean and tight. Not just the cables but the battery post also. The system will also need the same thing. Clean and tight. Its drawing alot from the battery and the alternator. Bad connections wreak havic on electrical stuff. Also the battery. Id have it tested also.
Fathershelper is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
germ
General Discussion
1
03-02-2012 12:15 PM
Lord Huggington
General Discussion
12
10-25-2010 07:51 PM
fckaffplz
Install related
6
09-03-2010 10:39 PM
risorial
Car Audio Technical Discussions
22
05-17-2010 10:09 PM
sonderegger
Car Audio Technical Discussions
8
03-20-2009 06:38 PM


Thread Tools
Search this Thread
Quick Reply: Subs Cut in and Out


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.