General Discussion General discussion about all things car audio, from pioneer, orion, alpine and eclipse.

Troubleshooter #1...

Old 02-28-2012, 09:37 AM
  #1  
50 Watt CAFz'r
Thread Starter
 
Join Date: Jun 2011
Posts: 320
Troubleshooter #1...

So about a month ago I was bumpin' on my way to pick up my kids and the sub crapped out. It didn't die- it just sounded TERRIBLE all of a sudden. I figure thats how DVC subs sound if a coil goes, turend off the sub output on my HU and kept going. Last week I ordered a replacement DD 2512.
Last night I was dotting my i's and crossing my t's hooking up my 8's in my doors, and when I folded my rear seat down, I found my sub hanging half in, half out of its hole in the enslosure. It had jarred itself loose, pulling every mounting screw out of the box.
Now not only do I need to get some t-nuts, I have an extra sun en route. Crap.
audio1der is offline  
Old 02-28-2012, 06:26 PM
  #2  
Administrator
 
Dukk's Avatar
 
Join Date: Feb 2006
Posts: 16,855
Ya know, that's pretty funny from over here.
Dukk is offline  
Old 02-29-2012, 09:12 PM
  #3  
500 Watt CAFz'r
iTrader: (1)
 
jstoner22's Avatar
 
Join Date: Jun 2009
Posts: 846
sounds like it is just time to build a box to house both of them!

pretty funny though lol
jstoner22 is offline  

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.