General Discussion General discussion about all things car audio, from pioneer, orion, alpine and eclipse.

Type X rate any problems?

Old 11-18-2004, 06:58 PM
  #2  
4000 Watt CAFz'r
iTrader: (3)
 
Haunz's Avatar
 
Join Date: Jun 2002
Posts: 4,218
Post

Alpine [img]graemlins/jack.gif[/img]
Haunz is offline  
Old 11-19-2004, 07:41 AM
  #4  
500 Watt CAFz'r
 
stillwater's Avatar
 
Join Date: Jul 2000
Posts: 870
Post

I have had 2 burn up as well.
stillwater is offline  
Old 11-19-2004, 10:07 AM
  #5  
1000 Watt CAFz'r
 
Join Date: Mar 2004
Posts: 1,093
Post

hmmmmmmmm...... i don't remeber type R's blowing up 1/2 as much as these new type x's....

Livin Loud
Livin - Loud is offline  
Old 11-19-2004, 10:46 AM
  #7  
1000 Watt CAFz'r
 
Join Date: Mar 2004
Posts: 1,093
Post

LOL>. what kind of box? ported, give size and port area!

Livin Loud
Livin - Loud is offline  
Old 11-19-2004, 11:54 AM
  #8  
500 Watt CAFz'r
 
Join Date: Aug 2001
Posts: 866
Post

I heard a guy have a problem with one. He said he hooked up a 1000 watt alpine and the out put was very low. Switched it for a new one and it got better. Both worked but had differant output.

I figured the spider may have had problems, and now that you state your problems defro.Maybe it was a problem.

They are terribly inefficient

[ November 19, 2004, 12:55 PM: Message edited by: slow/n\low ]
slow/n\low is offline  
Old 11-19-2004, 12:04 PM
  #9  
Level 3 Supporter
iTrader: (17)
 
Father Yuli's Avatar
 
Join Date: Oct 2000
Posts: 11,606
Post

i think u guys need to read manuals or just get proffesionals to install it.
Father Yuli is offline  
Old 11-19-2004, 12:12 PM
  #10  
4000 Watt CAFz'r
iTrader: (3)
 
Haunz's Avatar
 
Join Date: Jun 2002
Posts: 4,218
Post

hooked up a 1000 watt alpine and the out put was very low. Switched it for a new one and it got better. Both worked but had differant output [/QUOTE]

That sounds wakk [img]graemlins/freak.gif[/img]

At any rate, tearing spiders and burning coils with rated power (or maybe a lil more ) does not sound like a good product to me..

there is nothing wrong with Alpine, but I dont think they are 'all that' either...

In all fairness, a T1200.1 can probably put out in excess of 1400wRMS and maybe the one with the torn spider was in too large a box playing lil lower then it should have been.. [img]graemlins/dunno.gif[/img]
(like 20hz test signals on a bass track the customer forgot to mention.. lol ? )
Haunz is offline  

Thread Tools
Search this Thread
Quick Reply: Type X rate any problems?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.