Car Audio Technical Discussions Dedicated to the technical side of Car Audio.

need help with rock fosgate p3001 amp

Old 03-19-2014, 10:02 PM
  #1  
0 Watt CAFz'r
Thread Starter
 
Join Date: Mar 2014
Posts: 2
need help with rock fosgate p3001 amp

okay i have a rock fosgate p3001 manufactured 11/16/04 with the 2 crome plates on top, i am having issues with anytime i try to plug rca in to it kills sound to everything but it works fine if i plug the same plug into my other amp. i was pluying with it and the inside prong of the input can connect to either inside prong our outer lip of feed but if the outer part touches anything it kills all sound.


i have a pioneer hea unit and the wires coming out go to 4 dual strand wire that i soldered rca plugs to the end to plug into my 4 channel but i latter decided to add subs and was wanting to kill front speakers for subs till i can run more wire but i need to fix this problem first
newmans11 is offline  
Old 03-20-2014, 12:36 PM
  #2  
0 Watt CAFz'r
Thread Starter
 
Join Date: Mar 2014
Posts: 2
Any ideas
newmans11 is offline  
Old 03-20-2014, 02:05 PM
  #3  
2000 Watt CAFz'r
 
Join Date: May 2007
Posts: 2,141
I had a similar issue like this , I had a bad rca input when I connected my subs it took them out and it turned out the rca pin inside had broken off , took it to a local shop and they swapped the rca input for 50 bucks and never had an issue since , this very well sounds similar to your issue
luke99 is offline  

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.