General Discussion General discussion about all things car audio, from pioneer, orion, alpine and eclipse.

Car speakers making a rattling/poping sound??

Old 01-18-2008, 08:14 PM
  #1  
0 Watt CAFz'r
Thread Starter
 
Join Date: Nov 2007
Posts: 2
Car speakers making a rattling/poping sound??

hi i recently put a new kenwood deck KDC-MP208, Phenoix Gold 10" single sub,JBL Cs-300.1 amp into my 98 bmw 318ti (its a hatchback). so now i bought a pair of sony xplods 6x9s and had my mechanic install them in the back of my car. they are in the shelf board in the back(the guy cut two holes to make them fit). so now my problem is that when i turn up the music to a high level(i.e the max on the deck is 35 and the comfort level before it makes the noise is 20). once above 20 it makes a rattling/poping noise like the speakers are going to blow up. the thing i dont understand is when i have the car in park "most" times the noise doesnt happen but when im driving when i put the music up it makes the noise. also some songs dont make the noise like rock, but most rap songs i got makes the noise. i thought it was the board the speakers are mounted on was the problem like metal on metal, but the sound is coming from the speakers. Whats the matter here? everything i put in is 1 week old.
bugmenot is offline  
Old 01-18-2008, 09:52 PM
  #2  
0 Watt CAFz'r
 
Join Date: Apr 2005
Posts: 13
If you are running the new speakers off the built-in deck's amp, its probably distorting.

Also if you aren't running the speakers through either an active or passive crossover, it might be since you have too much bass thats contributing to the distortion when playing loud.

If you keep pumping too much bass through the speakers, you'll kill them quickly!

Another possibility is the bass from the sub thats installed in the rear trunk is causing some actual serious pressure on the 6x9's forcing them to distort. What happens when you disconnect the sub? Will the 6x9's sound / perform different then?

Last edited by 1V4N; 01-18-2008 at 09:56 PM.
1V4N is offline  
Old 01-19-2008, 03:45 PM
  #3  
0 Watt CAFz'r
Thread Starter
 
Join Date: Nov 2007
Posts: 2
ill give that a tire...on yahoo answers they said its damaged voice coils...im going to have it looked @ by the guy i got them from
bugmenot is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
army4ever
General Discussion
7
07-08-2011 02:02 AM
98talon
Off-topic Chat
3
01-20-2007 07:44 AM
matt_p
General Discussion
7
03-29-2006 04:08 PM
Way2slo
Install related
6
12-08-2004 04:05 AM


Thread Tools
Search this Thread
Quick Reply: Car speakers making a rattling/poping sound??


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.