General Discussion General discussion about all things car audio, from pioneer, orion, alpine and eclipse.

JL 10w6v2 by MRD-M605 at 2ohm (about 600wrms)

Old 02-27-2007, 07:44 AM
  #1  
50 Watt CAFz'r
Thread Starter
iTrader: (2)
 
belcom's Avatar
 
Join Date: Sep 2006
Posts: 249
JL 10w6v2 by MRD-M605 at 2ohm (about 600wrms)

I am looking at buying the 10w6v2 sub and it's dual 4ohm, which means I can run it at 2ohm. My amp will be pushing 600wrms. Will this sub take it without any reliability issues? Anybody experimented with W6s ?
belcom is offline  
Old 02-27-2007, 07:46 AM
  #2  
--SPECIAL ED--
iTrader: (2)
 
Join Date: Feb 2007
Posts: 482
if the power is kept clean it will be fine!
gumby! is offline  
Old 02-27-2007, 08:00 AM
  #3  
50 Watt CAFz'r
Thread Starter
iTrader: (2)
 
belcom's Avatar
 
Join Date: Sep 2006
Posts: 249
Originally Posted by gumby!
if the power is kept clean it will be fine!
and what exactly has to be done to keep it clean? good RCAs? good deck? good amp? proper ground?
belcom is offline  
Old 02-27-2007, 08:10 AM
  #4  
50 Watt CAFz'r
iTrader: (5)
 
Join Date: Nov 2003
Posts: 452
i'm running a hairo ver 600w rms to m 10w6v2 and it handles it like a champ. just watch the gain and you shouldn't have an issue.
smooth is offline  
Old 02-27-2007, 08:31 AM
  #5  
--SPECIAL ED--
iTrader: (2)
 
Join Date: Feb 2007
Posts: 482
Originally Posted by belcom
and what exactly has to be done to keep it clean? good RCAs? good deck? good amp? proper ground?
Just make sure that your gain is set properly "not full" make sure you have the subsonic filter set right and your crossover, dont put on a spl cd turn the gain up all the way and turn the volume up full for 5 minutes is all.


here is a link as you will see you are entering the danger zone but when set up properly it will be fine.
http://mobile.jlaudio.com/products_subs_pages.php?page_id=35
gumby! is offline  
Old 02-28-2007, 10:27 AM
  #6  
50 Watt CAFz'r
 
Join Date: Jan 2007
Posts: 149
to find out about clean power, check around for a gain setting tutoarial.
not sure if there is one here, but there is one on caraudio.com forum.
Keswick R/T is offline  
Old 02-28-2007, 11:43 AM
  #7  
50 Watt CAFz'r
Thread Starter
iTrader: (2)
 
belcom's Avatar
 
Join Date: Sep 2006
Posts: 249
everyone knows how to set the gains, that's nothing new to me. In any case the original question was regarding the 10w6v2 being able to handle 1.5 times the power (given that the gain was adjusted properly). I saw the JL site previously as well and I saw the danger zone picture. But I was just curious to hear from people who had experience.
belcom is offline  
Old 02-28-2007, 01:34 PM
  #8  
50 Watt CAFz'r
 
Reekor's Avatar
 
Join Date: Apr 2006
Posts: 151
Alpine amps melt at anything less then 4ohms. lol


Originally Posted by belcom
I am looking at buying the 10w6v2 sub and it's dual 4ohm, which means I can run it at 2ohm. My amp will be pushing 600wrms. Will this sub take it without any reliability issues? Anybody experimented with W6s ?
Reekor is offline  
Old 02-28-2007, 01:51 PM
  #9  
50 Watt CAFz'r
Thread Starter
iTrader: (2)
 
belcom's Avatar
 
Join Date: Sep 2006
Posts: 249
Originally Posted by Reekor
Alpine amps melt at anything less then 4ohms. lol
Are you serious? Have you blown an Alpine amp before? Sounds kinda hard to believe.
belcom is offline  
Old 02-28-2007, 02:03 PM
  #10  
4000 Watt CAFz'r
iTrader: (7)
 
Prolifik's Avatar
 
Join Date: Jan 2005
Posts: 4,180
i ran one at 0.5 ohm for a good month. then it melted.
Prolifik is offline  

Thread Tools
Search this Thread
Quick Reply: JL 10w6v2 by MRD-M605 at 2ohm (about 600wrms)


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.