General Discussion General discussion about all things car audio, from pioneer, orion, alpine and eclipse.

Problem with 12" MTX MXS1204

Old 02-16-2007, 01:05 PM
  #1  
0 Watt CAFz'r
Thread Starter
 
Join Date: Dec 2006
Posts: 36
Problem with 12" MTX MXS1204

Ok, I just got myself new MXS1204 12" subwoofers which were loaded in a Sledgehammer ported box. Don't get me wrong, they both are awesome hard pounding subs like i've never heard b4. However, out of the 2, one of them sounds really funny when the gain is cranked. Also, that one vibrates and "moves" a lot more than the other one. Is that a bad thing? What does that mean?

Thanks in advanced!
ian209 is offline  
Old 02-16-2007, 03:32 PM
  #2  
50 Watt CAFz'r
iTrader: (1)
 
Joshv06's Avatar
 
Join Date: Nov 2006
Posts: 113
Try running them with the gains set properly, i ran this sub for a while w/o any problems... BTW, you will notice a big difference with a custom box. My sledge hammer box didn't even compare to a custom one..
Joshv06 is offline  
Old 02-16-2007, 03:41 PM
  #3  
1000 Watt CAFz'r
iTrader: (1)
 
zinger002's Avatar
 
Join Date: Jul 2006
Posts: 1,445
play bass i love you by bassotronics off the realm of excursion website. it is a very good indicator if your subs are hooked up right or not.
zinger002 is offline  
Old 02-17-2007, 04:45 PM
  #4  
0 Watt CAFz'r
Thread Starter
 
Join Date: Dec 2006
Posts: 36
Ok, I set it to hooked up the subs through a mono connection and reversed the polarity for both... guess what? The OTHER one started having the problem. So I figured it was the polarity, and reversed the wires of the one with the problem, and voila! It was fine. Only problem is that when playing techno and trance music, some of the kicks sound really "funny" as in a "gurgling" noise. Is it just the sub or the amp? I have no idea.

Thanks for the help so far Appreciate it.

Originally Posted by zinger002
play bass i love you by bassotronics off the realm of excursion website. it is a very good indicator if your subs are hooked up right or not.
LOL, that took me 1 minute to figure out what that meant... lol. Sounds really funny

Btw, when i play that song, HOLY S***!!! My subs start moving VIOLENTLY! Is it safe for it to do that. On the REAL low notes, it MOVES SOO MUCH it scares me.... I stopped the song as soon as i saw that.

Last edited by ian209; 02-17-2007 at 04:59 PM.
ian209 is offline  
Old 02-17-2007, 05:23 PM
  #5  
1000 Watt CAFz'r
iTrader: (1)
 
zinger002's Avatar
 
Join Date: Jul 2006
Posts: 1,445
its hard on the driver. but man does it look cool.
zinger002 is offline  
Old 02-17-2007, 05:30 PM
  #6  
0 Watt CAFz'r
Thread Starter
 
Join Date: Dec 2006
Posts: 36
Another unaswered question:
Problem is that when playing techno and trance music, some of the kicks sound really "funny" as in a "gurgling" noise. Is it just the sub or the amp? I have no idea.
ian209 is offline  
Old 02-18-2007, 04:05 PM
  #7  
50 Watt CAFz'r
iTrader: (2)
 
Join Date: Feb 2007
Posts: 63
What is your crossover set at?
Greg_Canada is offline  
Old 02-18-2007, 04:26 PM
  #8  
0 Watt CAFz'r
Thread Starter
 
Join Date: Dec 2006
Posts: 36
Well unfortunately, my old amp's Xover only goes to lowest 60Hz.
ian209 is offline  
Old 02-18-2007, 05:52 PM
  #9  
--SPECIAL ED--
iTrader: (-1)
 
sunfired's Avatar
 
Join Date: Feb 2007
Posts: 452
60'S good but personally i'd turn it up to 100 ish,as far as the "gurgling" noise,it
may be some kind of port noise? its kinda hard to diagnose without hearing it in person.
Is the box there is designed for those particular subs?
sunfired is offline  
Old 02-18-2007, 06:36 PM
  #10  
0 Watt CAFz'r
Thread Starter
 
Join Date: Dec 2006
Posts: 36
yes the box was loaded with the MTX subs when i got it. And the gurgling noise isn't the ports, I know. When u put ure ears close to the sub, u can hear the noise. But it only happens on most my songs. (Most are hard trance) The bass sounds nice with no distortion, but the kicks always sound distorted and gurgly.
My old subs sounded like that too, but was a lot worst. Could it be the amp?
ian209 is offline  

Thread Tools
Search this Thread
Quick Reply: Problem with 12" MTX MXS1204


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.