General Discussion General discussion about all things car audio, from pioneer, orion, alpine and eclipse.

Sirius antenas

Old 02-03-2007, 12:00 PM
  #1  
50 Watt CAFz'r
Thread Starter
 
Join Date: Jul 2005
Posts: 119
Sirius antenas

So i have a serious beef with serius radio antenas. it seems that no matter how or were you place the antenas, after a couple of months they stop working. By this i men you get customers phonibg saying that their serius radio does not work anymore, it just says aquiring signal. now i have done lots of XM radios with no antena problems, and i am just wondering if anyone else seems to have problems with the sirius antenas or if it is just me.
JRSTAR is offline  
Old 02-03-2007, 08:56 PM
  #2  
500 Watt CAFz'r
 
Lethal's Avatar
 
Join Date: Mar 2004
Posts: 923
I've found it to be the receiver and not the antenna when that happens. Try hooking up the receiver to a working system and you'll find it to pop up the "acquiring signal" screen shortly.

It's a quick OTC exchange for the client and they can call in to switch esn's.
Lethal is offline  
Old 02-03-2007, 11:25 PM
  #3  
50 Watt CAFz'r
 
extreme1's Avatar
 
Join Date: Feb 2006
Posts: 146
Originally Posted by Lethal
I've found it to be the receiver and not the antenna when that happens. Try hooking up the receiver to a working system and you'll find it to pop up the "acquiring signal" screen shortly.

It's a quick OTC exchange for the client and they can call in to switch esn's.

I've found more Docks quit than tuners and antenna's.
extreme1 is offline  
Old 02-05-2007, 11:28 AM
  #4  
50 Watt CAFz'r
Thread Starter
 
Join Date: Jul 2005
Posts: 119
Originally Posted by extreme1
I've found more Docks quit than tuners and antenna's.
I would agre with that on the old sirius sportsters, if the reciever wasn't completly tight in the dock you would have issues, but i have noticed in the last few months thatr a lot of the sirius antenas especialy the big round ones with the silver center have been having alot of issue.
JRSTAR is offline  
Old 02-07-2007, 05:17 PM
  #5  
50 Watt CAFz'r
 
Join Date: Apr 2006
Posts: 115
if the antenna is broken the unit wont say aquiring signal it will say no antenna detected
D.Sanchez is offline  
Old 02-08-2007, 11:11 AM
  #6  
50 Watt CAFz'r
Thread Starter
 
Join Date: Jul 2005
Posts: 119
Originally Posted by D.Sanchez
if the antenna is broken the unit wont say aquiring signal it will say no antenna detected
if the antenna is pluged in to the unit it will say aquiring signal, only when the antena is completlyu unpluged will it say antena not detected. ive had people say the havent had a signal for 2 weeks straight, so i grab a new antena plug it in and presto, perfect signal.
JRSTAR is offline  
Old 02-10-2007, 05:39 PM
  #7  
500 Watt CAFz'r
 
Join Date: Oct 2005
Posts: 649
were stocking spare sirrius ant. now. that mite be an sign that they know of problems. Just a heads up, if your installing a Stilletto and it says "no ant detected" ..check you power to the unit. It wont recieve ant signal from the car without 12 volt
ShonBesharah is offline  
Old 02-11-2007, 05:59 AM
  #8  
50 Watt CAFz'r
 
Join Date: Apr 2006
Posts: 115
not always true jstar, when pulling antena thru firewall or with factory defect the antenna may break or be broken regardless of it being perfectly plugged in it will say antenna not detected, its generaly all or none in regards to the antenna working...what i mean by that is i havent seen any inbetween its been the antennna is %100 A OK or its %100 fubar
D.Sanchez is offline  
Old 02-14-2007, 12:59 AM
  #9  
50 Watt CAFz'r
 
Join Date: Apr 2004
Posts: 445
We have come across the same issue, install an unit and few months down the road the unit displays "Aquiring Signal".

Double check the Ant with no problems found, changed the ant problem solved, then a few days later the radio itself packed it in........we have exchanged more of the radios than the XM.

That is why when people asked, I sell them XM. I have had nothing but problems with Sirius.
Claudio Piccolo is offline  
Old 02-19-2007, 12:51 PM
  #10  
50 Watt CAFz'r
Thread Starter
 
Join Date: Jul 2005
Posts: 119
Originally Posted by ShonBesharah
were stocking spare sirrius ant. now. that mite be an sign that they know of problems. Just a heads up, if your installing a Stilletto and it says "no ant detected" ..check you power to the unit. It wont recieve ant signal from the car without 12 volt
Man i could have reallt used that tidbit of info on fri, before i figured it out for myself. i couldn't figure out why the stiletto wouldn't work plugged into our home antenna in the bay, i nby this time thought sirius had given us a bad batch of stileto's. No signal in car or pluged in to home ant. after pulling out my hair i finally figured out that the cradle needed to be powered.
JRSTAR is offline  

Thread Tools
Search this Thread
Quick Reply: Sirius antenas


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.