General Discussion General discussion about all things car audio, from pioneer, orion, alpine and eclipse.

subs

Old 06-29-2007, 11:37 AM
  #1  
--SPECIAL ED--
Thread Starter
 
gti_stu's Avatar
 
Join Date: Feb 2007
Posts: 2
subs

my subs are making a scratching noise somebody told me they were blown but they are still making bass. what else could it be
gti_stu is offline  
Old 06-29-2007, 12:48 PM
  #2  
50 Watt CAFz'r
 
theif's Avatar
 
Join Date: Jul 2006
Posts: 336
voice coil out of alignment , soon to be blown .
theif is offline  
Old 06-29-2007, 01:49 PM
  #3  
50 Watt CAFz'r
iTrader: (1)
 
isaacs6's Avatar
 
Join Date: Nov 2006
Posts: 55
solid connection to the battery? I had a problem similar to this and just had a bad connection.
isaacs6 is offline  
Old 06-29-2007, 04:17 PM
  #4  
50 Watt CAFz'r
 
Sound_Deamon's Avatar
 
Join Date: Feb 2007
Posts: 330
if you physically push on your subs do you hear a scratching noise ?? ... if you do then it is highly posible that your voice coils are rubbing ... in that case be carefull running them ... you can have serius problems (blow amp).
Sound_Deamon is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ported
Car Audio Wanted (WTB)
0
08-19-2007 07:48 PM
splescort
Car Audio Wanted (WTB)
4
04-07-2006 09:43 AM


Thread Tools
Search this Thread
Quick Reply: subs


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.