General Discussion General discussion about all things car audio, from pioneer, orion, alpine and eclipse.

amp went up in smoke :(

Old 03-24-2008, 06:33 PM
  #1  
50 Watt CAFz'r
Thread Starter
iTrader: (2)
 
Join Date: Aug 2006
Posts: 318
amp went up in smoke :(

she lasted 5-6 years but bit the bullet last week
Name:  ampsubs004.jpg
Views: 65
Size:  33.8 KB
Name:  amp013.jpg
Views: 98
Size:  9.5 KB
the carnage
Name:  amp-023.jpg
Views: 66
Size:  171.9 KB
Name:  amp-025.jpg
Views: 52
Size:  94.4 KB
now those are the only bad parts on my BX1000D, i came across a BX1500D with blown mosfets and im thinking about putting my BX1000D parts into it, anyone know if the mosfets would be teh same?
BX1500D
Name:  BX1500D2.jpg
Views: 45
Size:  117.3 KB
Name:  BX1500D2b.jpg
Views: 54
Size:  77.4 KB
need some opinions here does it look like the resistors might be fine? to me it jsut looks liek the smoke stained most of them

im guessing it would be easier to fix my amp but clearly i would ratehr have a 1500 RMS amp then a 1000 RMS amp
_HeC_ is offline  
Old 03-24-2008, 08:07 PM
  #2  
MTA
2000 Watt CAFz'r
iTrader: (1)
 
MTA's Avatar
 
Join Date: Nov 2003
Posts: 2,282
well the only way to tell is find a good fet on the 1000 and write down the part number and compare it to the fet on the 1500.. the resistors..clean one and read the color code..I would just replace them all in the series..resistors are only about 5-10cents a peice... and if u replace the fets u should be replacing the whole set not just the blown ones as the ones that remain might be slightly damaged and will become the weakest link once again.... but this is only my 2cents worth...there is always a reason an amp blows..so it wont be just a simple replace the burn parts... you may also have burnt drivers or IC's... the 1000 looks like part of the output section smoked nicely... and the 1500 looks like powersupply..so chances are that your PMW IC is fried too
MTA is offline  
Old 03-24-2008, 08:23 PM
  #3  
MTA
2000 Watt CAFz'r
iTrader: (1)
 
MTA's Avatar
 
Join Date: Nov 2003
Posts: 2,282
well the ones that are brown,black,brown,gold are 100ohm +-5%.... the brown,violet,brown,gold is 270 +-5% good luck the fets should be either irfz44ns or if1405 but I could be wrong... u'll just have to take the heatsink clamps off and read them


btw..the one on the left that is just a white blotch will be a 100ohm
Attached Thumbnails amp went up in smoke :(-bx1500resistors.jpg  
MTA is offline  
Old 03-24-2008, 08:30 PM
  #4  
50 Watt CAFz'r
iTrader: (8)
 
Join Date: Feb 2006
Posts: 216
blown amp

It sure looks pretty blown. To give you some opinion, we do specialized in car audio repair and we definitely don't recommend you to take or transfer mosfet components from one amp to another regardless if its the same or not. Main reason is that mosfets are pretty sensitive when it comes to voltage value specially that it has been used from a different application. You may sometimes get away from it but based on our experience, it doesn't normally last longer. The least that I can offer is if you can send or drop it over, we'll check it for you at no charge. S & S ELECTRONICS (647) 435 -5980.

Originally Posted by _HeC_ View Post
she lasted 5-6 years but bit the bullet last week


the carnage


now those are the only bad parts on my BX1000D, i came across a BX1500D with blown mosfets and im thinking about putting my BX1000D parts into it, anyone know if the mosfets would be teh same?
BX1500D


need some opinions here does it look like the resistors might be fine? to me it jsut looks liek the smoke stained most of them

im guessing it would be easier to fix my amp but clearly i would ratehr have a 1500 RMS amp then a 1000 RMS amp
4boyssss is offline  
Old 03-24-2008, 11:55 PM
  #5  
50 Watt CAFz'r
Thread Starter
iTrader: (2)
 
Join Date: Aug 2006
Posts: 318
i want to replace the resistors but the local electronics store closed down and the only place to go in london is The Source :S lol

ive gotten away with just replacing a couple mosfets before and never had a issue with the amp again

S&S is there any chance you can sell me the mosfets and resistors if i give you the numbers/color codes off them? i really dont wanna deal with the US and customs to get a couple small things sent to me...ohh and i got a 15" RE SX, u guys recone them?

MTA ur right my output got blown on the 1000D, amp still turns on and as for the 1500D the guy said it still turned on but i didnt think that was possible with blown mosfets
_HeC_ is offline  
Old 03-25-2008, 12:09 AM
  #6  
50 Watt CAFz'r
iTrader: (8)
 
Join Date: Feb 2006
Posts: 216
parts

As far as parts goes, we could sell it to you if you're confident enough to do it yourself. Simply let us know what you need and got no problem sending it as long as we do have them in stock.

Regarding the sub, we'll see if we could get the kits for it and let you know.

Originally Posted by _HeC_ View Post
i want to replace the resistors but the local electronics store closed down and the only place to go in london is The Source :S lol

ive gotten away with just replacing a couple mosfets before and never had a issue with the amp again

S&S is there any chance you can sell me the mosfets and resistors if i give you the numbers/color codes off them? i really dont wanna deal with the US and customs to get a couple small things sent to me...ohh and i got a 15" RE SX, u guys recone them?

MTA ur right my output got blown on the 1000D, amp still turns on and as for the 1500D the guy said it still turned on but i didnt think that was possible with blown mosfets
4boyssss is offline  
Old 03-25-2008, 12:14 AM
  #7  
50 Watt CAFz'r
Thread Starter
iTrader: (2)
 
Join Date: Aug 2006
Posts: 318
awesome thank you! the few shops i contacted didnt wanna sell me parts as they wanted to make alot more money off me, thumbs up to you guys for helping poeple out!

i have fixed a few amps before so i feel pretty confident doing it and if it doesnt work out for some reason then im out a little bit of cash, im jsut trying to do this on a budget as i need something in my car and dont have the cash to spare for a new amp as i gotta sink atleast $500 into my summer car to get it back to road worthy as my plates expire on my beater at the end of april and shes not worth hte moeny for parts to make it pass etest haha
_HeC_ is offline  
Old 03-25-2008, 12:52 AM
  #8  
Level 3 Supporter
iTrader: (17)
 
Father Yuli's Avatar
 
Join Date: Oct 2000
Posts: 11,606
u could always spend $300 and get another brand new 1500 hifonics amp on ebay. Probably less than $300.
Father Yuli is offline  
Old 03-25-2008, 04:38 PM
  #9  
500 Watt CAFz'r
iTrader: (3)
 
LOWTONEZ's Avatar
 
Join Date: Apr 2007
Posts: 872
^^^ agree.
LOWTONEZ is offline  
Old 03-25-2008, 06:25 PM
  #10  
50 Watt CAFz'r
Thread Starter
iTrader: (2)
 
Join Date: Aug 2006
Posts: 318
it would be $260+ from ebay, why spend $300 when i can have the same amp working for under $100?
_HeC_ is offline  

Thread Tools
Search this Thread
Quick Reply: amp went up in smoke :(


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.