General Discussion General discussion about all things car audio, from pioneer, orion, alpine and eclipse.

Help with amp/speaker set up!

Old 09-11-2007, 01:23 AM
  #1  
0 Watt CAFz'r
Thread Starter
 
AudiophileXX's Avatar
 
Join Date: Sep 2007
Posts: 2
Help with amp/speaker set up!

I have Aline SPX-13PRO's (5 1/4) in front dash (TW's on A-Pillar) w/JL 300/2. Two forward-firing sealed JL 6W0's under front seat's 1L+1R w/Eclipse EA3422 (bridged). Boston NX-57 (mid-rear, maybe!). Two rear-firing sealed JL 12W0's w/JL E1200. I need help with configuring x-overs! Especially my 6W0's (mid-base)! Also, can I connect my NX-57's (50W RMS), and my 6W0's (75W RMS) to the same terminals on my "bridged" amp (140W RMS), or should I take them out of the picture all together? If so,what if any are the draw-backs to doing this? I don't want to take away from my "front-stage", just add some rear fill-in! My system is set up as 3-way (High-Mid-Low)! Please help!!

Thanks:
dunno:

Last edited by AudiophileXX; 09-11-2007 at 01:32 AM.
AudiophileXX is offline  
Old 09-11-2007, 09:09 AM
  #2  
0 Watt CAFz'r
Thread Starter
 
AudiophileXX's Avatar
 
Join Date: Sep 2007
Posts: 2
Red face

Come on guys, I need some general help here! Anyone? Thx
AudiophileXX is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
anitutam
Car Audio Technical Discussions
5
06-06-2011 08:46 PM
vip3r87
Car Audio Wanted (WTB)
0
04-03-2007 03:09 PM
sombasol
General Discussion
10
05-26-2006 04:57 PM


Thread Tools
Search this Thread
Quick Reply: Help with amp/speaker set up!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.