General Discussion General discussion about all things car audio, from pioneer, orion, alpine and eclipse.

HELP!! (sub problem)

Old 04-02-2008, 09:13 PM
  #1  
0 Watt CAFz'r
Thread Starter
 
Join Date: Feb 2008
Posts: 17
HELP!! (sub problem)

Hey ive got a sub problem i just bought brand new 2 boston g2s and a alpine mrp-m650 im running my subs at 4 ohms. I just got it proffesionally installed and i was listenin to a loud song and my left sub completely stopped working...any ideas??
archenemy236 is offline  
Old 04-02-2008, 09:16 PM
  #2  
1000 Watt CAFz'r
iTrader: (1)
 
Jo-Psyko's Avatar
 
Join Date: Feb 2008
Posts: 1,301
just the left one? and they are wired together to the amp (mono)? then you need to take the sub out and make sure its still hooked up and if the wiring is fine you need to take the sub back!
Jo-Psyko is offline  
Old 04-02-2008, 09:51 PM
  #3  
1000 Watt CAFz'r
iTrader: (1)
 
danyman's Avatar
 
Join Date: Aug 2007
Posts: 1,978
if it was installed proffetionaly go back and see them for waranty work depending how long it was installed
danyman is offline  
Old 04-02-2008, 09:57 PM
  #4  
0 Watt CAFz'r
Thread Starter
 
Join Date: Feb 2008
Posts: 17
i got them installed 2 days ago, i think a wire inside the box might have come loose...wouldnt both have blown if overpowered?? and it stopped so randomly too
archenemy236 is offline  
Old 04-02-2008, 09:58 PM
  #5  
0 Watt CAFz'r
Thread Starter
 
Join Date: Feb 2008
Posts: 17
its also a mono amp (1 channel)
archenemy236 is offline  
Old 04-02-2008, 09:59 PM
  #6  
1000 Watt CAFz'r
iTrader: (1)
 
danyman's Avatar
 
Join Date: Aug 2007
Posts: 1,978
i think its just a loose wire by the sounds of it... just pop the sub out if its all still wired well could be the sub
danyman is offline  
Old 04-02-2008, 10:01 PM
  #7  
1000 Watt CAFz'r
iTrader: (1)
 
Jo-Psyko's Avatar
 
Join Date: Feb 2008
Posts: 1,301
if its awire go back and slap who ever put it in..... what the hell you pay them for?!
Jo-Psyko is offline  
Old 04-02-2008, 10:04 PM
  #8  
0 Watt CAFz'r
Thread Starter
 
Join Date: Feb 2008
Posts: 17
lol im gonna go tommorow at lunch time and let them do it i paid them 40 bucks to put them in the box and tune my amp
archenemy236 is offline  
Old 04-02-2008, 10:06 PM
  #9  
1000 Watt CAFz'r
iTrader: (1)
 
Jo-Psyko's Avatar
 
Join Date: Feb 2008
Posts: 1,301
who you go to?
Jo-Psyko is offline  
Old 04-02-2008, 10:07 PM
  #10  
0 Watt CAFz'r
Thread Starter
 
Join Date: Feb 2008
Posts: 17
audio warehouse in saskatoon our locals
archenemy236 is offline  

Thread Tools
Search this Thread
Quick Reply: HELP!! (sub problem)


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.