General Discussion General discussion about all things car audio, from pioneer, orion, alpine and eclipse.

Hmmm, my ground...

Old 01-28-2007, 05:10 PM
  #1  
500 Watt CAFz'r
Thread Starter
iTrader: (2)
 
Lspade69's Avatar
 
Join Date: Jan 2006
Posts: 607
Hmmm, my ground...

Ok, so I pulled the 0 gauge positive run from my old vehicle and I now have enough to have a positive and negative run in my new one, haha. I am very very happy now because having a 0 gauge positve and ground lets me know that my amp is not trying to "suck" electricity through all of the bondo and stuff that holds my chasis together. My question is: is it a good idea for me to throw a distribution block onto the end of my ground wire and run some 4 gauge from my amps to this block? I remember reading something about having distribution blocks on grounds and how it is kindof a stupid idea or something like that. Thanks for the help guys.
Lspade69 is offline  
Old 01-28-2007, 05:52 PM
  #2  
Guest
 
Mini Steve's Avatar
 
Join Date: Aug 2003
Posts: 961
In both my rides I have posative and negative distro blocks. Even if you don't use them this mintute the option is there down the road. So yes in my opinion do both.
Mini Steve is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
aliasmel
Install related
3
06-18-2007 08:12 PM
Cavalier Chunk
Off-topic Chat
7
07-09-2006 06:52 PM
Cavalier Chunk
Off-topic Chat
1
03-03-2006 09:09 PM
Dereck Waller
General Discussion
1
11-24-2004 08:05 PM
68Brick
Install related
6
06-11-2003 03:29 PM


Thread Tools
Search this Thread
Quick Reply: Hmmm, my ground...


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.