General Discussion General discussion about all things car audio, from pioneer, orion, alpine and eclipse.

Need Amp repaired

Old 08-23-2004, 03:18 PM
  #1  
500 Watt CAFz'r
Thread Starter
 
Join Date: Feb 2003
Posts: 870
Post

Seems for some reason my USA-2000x kicked the can. It just needs some things de-soldered and replaced, anyone know of a place to do this? I have been trying to desolder the damn parts and its not as easy as i thought it would be.
scarlemthug is offline  
Old 08-23-2004, 03:27 PM
  #2  
1000 Watt CAFz'r
 
Join Date: Aug 2002
Posts: 1,239
Post

add gobs of solder to the 3 pins - swirl your iron
around a bit.. the remove part with plyers.
Then suck up the rest of the solder with a sucker.
Seahag is offline  
Old 08-23-2004, 03:53 PM
  #3  
500 Watt CAFz'r
Thread Starter
 
Join Date: Feb 2003
Posts: 870
Post

I have one of the desoldering irons from radio shack. Prolly not the best for de-soldering but its all i could find. I just cant seem to get the solder to heat up and get sucked up on some of the places. I dont wanan scratch up the board anymore than I have already so if someone knows a place in the GTA that will repair it for fairly cheap that would be awesome.
scarlemthug is offline  
Old 08-23-2004, 04:16 PM
  #5  
1000 Watt CAFz'r
 
Join Date: Aug 2002
Posts: 1,239
Post

Good luck getting that to work with most transistors.. maybe I had a bad brand.
Seahag is offline  
Old 08-23-2004, 04:35 PM
  #6  
500 Watt CAFz'r
Thread Starter
 
Join Date: Feb 2003
Posts: 870
Post

[url]http://www.radioshack.ca/estore/Product.aspx?language=en-CA&catalog=RadioShack&category=Soldering+Tools&pro duct=6402090[url]

is that what you recommend? I hope that stuff will work cause I wanna get down to active surplus and get the replacement parts ASAP.
scarlemthug is offline  
Old 08-23-2004, 04:58 PM
  #9  
500 Watt CAFz'r
Thread Starter
 
Join Date: Feb 2003
Posts: 870
Post

Aight i will go check it out tommorow, thanks for the help [img]smile.gif[/img] . I just hope im not ****ing up the board of my amp and that this will fix the problem. Now if I could only figure out why the amp will stay on without the remote wire even connected.
scarlemthug is offline  
Old 08-25-2004, 11:56 AM
  #10  
500 Watt CAFz'r
Thread Starter
 
Join Date: Feb 2003
Posts: 870
Post

thanks for the tip on the desoldering btraid, that helped make the process easier. I still need to go down to active surplus to get the replacement parts. Pretty much what im guessing happened is the amp overheated from being on for a very long time and blew the amplifier section on the board. 18 of those cylinder cap looking pieces blew and the amp goes straight into protection if it was hooked up. I still dont know how im suppose to figure out why the remote part of the amp is busted and the amp wont turn off.

Anyone know what I should be looking for on the board as far as the remote connection to turn the amp on?
scarlemthug is offline  

Thread Tools
Search this Thread
Quick Reply: Need Amp repaired


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.