General Discussion General discussion about all things car audio, from pioneer, orion, alpine and eclipse.

New amp, less bass..

Old 03-27-2006, 08:19 AM
  #1  
0 Watt CAFz'r
Thread Starter
 
Join Date: Dec 2003
Posts: 21
New amp, less bass..

hey guys, i upgraded my amp..i had a small kenwood 2 channel amp..it was putting out around 150-200rms...now i got a visionik mono block 1200rms amp..and i had more bass from the small kenwood..i have all the ***** in the middle..gain, bass boost, some filter thing..any ideas on why this is??? i have 2 10 mtx subs wired to 2ohms..the amp is 2ohm stable..

thanks..
G_50B is offline  
Old 03-27-2006, 08:39 AM
  #2  
500 Watt CAFz'r
iTrader: (16)
 
splescort's Avatar
 
Join Date: Feb 2006
Posts: 612
.

teh filter might be a sub sonic filter if it is then turn it all the way down and see what happends and some thing that i found with my visonik v900xd is that i had to have the bass EQ dial cranked to +18DB to get the volume also with the larger amp did u upgrade the fuse under the hood and have you checked all the controls on the deck fader balance sub control xovers on the deck if any please give the model number of amp that you have and i might be able to help u out better.
splescort is offline  
Old 03-27-2006, 09:00 AM
  #3  
0 Watt CAFz'r
Thread Starter
 
Join Date: Dec 2003
Posts: 21
The amp is

V2118
1200 Watt Mono
Amplifier with Remote

the subs are 250rms each, 4ohms each

the deck is a kenwood deck, it doesnt have subwoofer controls on it..but with the old amp everything sounded great...

sometimes the bass just sounds HORRIBLE and i have to switch tracks..
G_50B is offline  
Old 03-27-2006, 09:22 AM
  #4  
500 Watt CAFz'r
iTrader: (16)
 
splescort's Avatar
 
Join Date: Feb 2006
Posts: 612
.

well the specs on the amp is
V2118
1200 Watt Mono
Amplifier with Remote

1 x 400W Rms @ 4Ω
1 x 560W Rms @ 2Ω
1 x 800W Rms @ 1Ω
1 x 600W Max @ 4Ω
1 x 800W Max @ 2Ω
1 x 1200W Max @ 1Ω

Class AB Circuitry
0-18dB Variable Bass Boost
200mV -8V RCA Voltage Input
S/N >90dB
24dB 40-250 Hz Variable LP & HP Filter
Tri-Mode Capable
2 Ohm Stereo, 4 Ohm Mono Stable
24dB 20-50Hz Variable Subsonic Filter
High and Low Level Inputs
0.05% THD
Remote Bass Control (except V2218)
Thermal Short and Overload Protection
RCA Line Outputs
Built in Cooling Fans (except V2218)


Dimensions (H x W x L):
2.9" x 10.8" x 16.5"

and you said that u have the subs down to 2 ohm so the subs are getting 560rms and the subs are i am guessing MTX 6000s and you said that they are 250rms so you are over powering them by 60 watts which is not too bad cus i dont think that the amp is really doing 560 rms also where do you have the LP and HP switch? also the amp has Class AB Circuitry which means that the amp is roughly 50% Efficient so for it so produce 560 watts rms it needs to take in 1120 watts rms from your charging system so with the car running and the alt and battery at 14.4 volts you need 77.78 amps to make 560 rms and i dont think that your car can power that amp. unless u have a High out put alt.

anyways i would be checking where the lowpass (LP) and HP (high pass) switch is or just listen to the subs and put your head right in front of the subs and if you hear the voice of the singer then you have it in the wrong spot and do your subs move as much as they did before? that would also tell me that you have the switch in the wrong spot you want the switch in on the LP also with the Switchable on/off Bass Boost turn it on and turn the gain down and see what happens. also the Remote Bass Control unplug it when i was talking to visonik's head office in the states they told me that the bass ***** make u lose 22% of the amps out put so your amp is only doing 436.8rms watts @ 2 ohm which i am not sure if i beleive them on that... but hell its worth a try.

well give that all a try
splescort is offline  
Old 03-27-2006, 01:07 PM
  #5  
500 Watt CAFz'r
 
RedZone's Avatar
 
Join Date: Jan 2003
Posts: 708
plus with a cheaper amp you may have to turn the gain up more then to the middle. my pioneer didnt make any noise( or very little) untill i had the gain at least 3/4 of the way up.
RedZone is offline  
Old 03-27-2006, 01:36 PM
  #6  
4000 Watt CAFz'r
iTrader: (66)
 
MR2NR's Avatar
 
Join Date: Dec 2003
Posts: 6,420
Unplug one sub and see if it sounds better or not. If it does, one sub was wired out of phase.
MR2NR is offline  
Old 03-27-2006, 02:22 PM
  #7  
Administrator
 
Dukk's Avatar
 
Join Date: Feb 2006
Posts: 16,855
Lightbulb

^
Dukk is offline  
Old 03-27-2006, 10:24 PM
  #8  
2000 Watt CAFz'r
iTrader: (11)
 
BigRedGuy's Avatar
 
Join Date: Nov 2000
Posts: 2,383
Thumbs up

/\ Are we making bets on this one??...........

That amp should be hitting those subs pretty hard....
BigRedGuy is offline  
Old 03-28-2006, 10:47 PM
  #9  
4000 Watt CAFz'r
 
Back-2-Bassiks's Avatar
 
Join Date: Feb 2006
Posts: 5,939
and if they are out of phase and they get rewired, my moneys on them going up in smoke within a week
Back-2-Bassiks is offline  
Old 03-28-2006, 11:07 PM
  #10  
500 Watt CAFz'r
 
Join Date: Mar 2006
Posts: 509
Originally Posted by MR2NR
Unplug one sub and see if it sounds better or not. If it does, one sub was wired out of phase.

bet thats it :P i always do that when im goin fast n not paying attention
matt_p is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
rolex
General Discussion
10
03-02-2012 11:50 PM
SOULMUSIC
Enclosure Design & Construction Help
12
06-19-2011 06:00 AM
footballdad
General Discussion
13
11-03-2010 09:26 PM
G_50B
Install related
4
04-02-2006 08:49 PM
Kwalsh24
General SQ
27
08-05-2004 09:40 PM


Thread Tools
Search this Thread
Quick Reply: New amp, less bass..


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.