General Discussion General discussion about all things car audio, from pioneer, orion, alpine and eclipse.

new speakers

Old 12-06-2007, 03:35 PM
  #1  
0 Watt CAFz'r
Thread Starter
 
Join Date: Dec 2007
Posts: 12
new speakers

i installed 2 new speakers in the rear the same kind that was instaled in the front from futureshop and only 1 side works and somtimes it cuts out at random(i just tied the power wire onto it) would my decks fuse be why its not getting enough power because one time (the second day i was playing it my deck shut off and the fuse blew) and the speedometer stopped working (fuse) would putting a larger fuse in it make all the speakers work?? btw i have these speakers

http://www.futureshop.ca/catalog/proddetail.asp?logon=&langid=EN&sku_id=0665000FS10 085400&catid=

so you see its 75watts rms when i turn on my deck does it it turn on 75wats x4?? or no?
currytillidie is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
hoponpop
General SQ
9
11-02-2008 11:12 PM
hoponpop
General Discussion
2
11-02-2008 11:10 PM
shane_colton
Car Audio Wanted (WTB)
0
04-16-2007 10:52 PM
Muckaluck
General Discussion
4
09-28-2003 01:52 PM
quicksilver545
Install related
5
08-30-2003 05:37 PM


Thread Tools
Search this Thread
Quick Reply: new speakers


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.