General Discussion General discussion about all things car audio, from pioneer, orion, alpine and eclipse.

Bass knob clipping light

Old 02-02-2012, 05:44 PM
  #1  
0 Watt CAFz'r
Thread Starter
iTrader: (2)
 
eldico's Avatar
 
Join Date: Aug 2009
Posts: 33
Bass **** clipping light

Ok so I got my new amp toda(DC 2.0k) and I hooked everything up and the clipping light seems to stay lit no matter what position the gain is in. I'm running 2 Mach 5 ixl 10's dual 1 ohm. 1 makes a funny sound while playing. Any thoughts would be nice.
eldico is offline  
Old 02-02-2012, 08:33 PM
  #2  
500 Watt CAFz'r
iTrader: (1)
 
IT Hz's Avatar
 
Join Date: May 2009
Posts: 737
disconnect the woofer leads from the amp and see if the light turns off, are your subs wired for a 1 ohm load ? are they wired correctly per voice coil ? maybe you have a woofer out of phase. Check the impedance at each voicecoil and see if there is any difference.
IT Hz is offline  
Old 02-05-2012, 09:02 PM
  #3  
500 Watt CAFz'r
 
Njord's Avatar
 
Join Date: Oct 2007
Posts: 519
Those lights usually indicate input signal clipping. Try disconnecting the rca's from the amp and see if the light turns off. A small bit of noise (like alternator whine) can/will cause the light to go on, even though it may not be audible.
Njord is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
wiltshire559
Car Audio Wanted (WTB)
4
06-03-2007 04:31 PM
Xtek
Car Audio Wanted (WTB)
0
02-19-2007 10:44 AM
joey36
General Discussion
6
09-01-2006 05:06 PM
splescort
Car Audio Wanted (WTB)
0
03-06-2006 05:24 PM
Shawnlh
General Discussion
32
03-09-2005 11:59 AM


Thread Tools
Search this Thread
Quick Reply: Bass knob clipping light


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.