General Discussion General discussion about all things car audio, from pioneer, orion, alpine and eclipse.

infinity amp making noises

Old 04-10-2008, 09:39 PM
  #1  
50 Watt CAFz'r
Thread Starter
 
alti117's Avatar
 
Join Date: Jan 2007
Posts: 118
Unhappy infinity amp making noises

ok so a while back i posted that my infinity 7541a 4 channel amp was cutting out and making poping noises well the other day i decided to hook it back up after a coupple months of no use and to my surprise the amp worked and played music as normal. i have no idea what could have caused the problem but now when i power up my system i can hear my 4 channel amp powering up through the speakers. im not sure exactly how to explain the sound almost like a hum but then it goes away after about a second. iv checked my grounds and power connections, any other suggestions?
alti117 is offline  
Old 04-10-2008, 09:51 PM
  #2  
4000 Watt CAFz'r
iTrader: (5)
 
Join Date: Jan 2005
Posts: 4,643
try redoing the ground
i would try a bench test with it
zzzzzzz is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Jazz
General Discussion
0
11-25-2009 08:18 PM
dongchen_han
General Discussion
14
12-24-2006 11:29 PM
conn007
General SQ
13
02-28-2006 05:23 PM
bassytempo
Install related
33
07-16-2004 11:55 AM
Rag'nor
General Discussion
9
09-12-2003 10:08 AM


Thread Tools
Search this Thread
Quick Reply: infinity amp making noises


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.