Kenwood Head Unit Question - Car Audio Forumz - The #1 Car Audio Forum

General Discussion General discussion about all things car audio, from pioneer, orion, alpine and eclipse.

Kenwood Head Unit Question

Reply

 
 
 
Old 02-21-2010, 03:57 PM
  #1  
50 Watt CAFz'r
Thread Starter
iTrader: (4)
 
Mahna Mahna's Avatar
 
Join Date: Feb 2008
Posts: 495
Kenwood Head Unit Question

Club friend has a question about a Kenwood kvt-815 DVD head unit.

Seems there is some sort of connector on the back he can't make sense of.

If anyone can help, I would appreciate it.

Pic of connector in link below. Looks like a silver metal BUS or plug in.

http://ccfbg.com/forum/viewtopic.php?t=10495

Thanks again
Mahna Mahna is offline  
Reply With Quote
Old 02-21-2010, 11:15 PM
  #2  
MTA
2000 Watt CAFz'r
iTrader: (1)
 
MTA's Avatar
 
Join Date: Nov 2003
Posts: 2,282
looks to me like you need the center harness which is the power harness... the other one that you have in your hand in the lst picture belongs to a bus cable that plugs into a "brain" (tuner/amplifier unit) that has your antenna connection plus your speaker outs and all RCA connections.... this deck is useless without the bus cable and "brain" ... next time buy from smart theives if thats the case
MTA is offline  
Reply With Quote
Old 02-21-2010, 11:22 PM
  #3  
500 Watt CAFz'r
 
Sinemeup's Avatar
 
Join Date: Apr 2006
Posts: 633
I went to the Kenwood site (they do have owners/install manuals) it says this wire is for accessory wire (2) I'm guessing this was going to be for adding upgrades to your head unit (and then I'm going to guess kenwood decided on going a different route... It is an excelon however its now 6 years old... can't say as I noticed USB on the deck did you?
Sinemeup is offline  
Reply With Quote
Old 02-21-2010, 11:39 PM
  #4  
I suck a bozzack for a nickel
iTrader: (5)
 
jonesbrooklyn's Avatar
 
Join Date: Aug 2006
Posts: 2,681
the black plug needs to plug into a brain. Your boy should have gotten a really long cord which will connect the deck to the brain. I had the KVT 717 and there is no difference in the KVT series. The orange plug is for video out, preferably a back up camera. The yellow plug you are holding in your hand is a harness to connect the deck to to factory plug of the vehicle. I hope that is not all you got. That deck comes with a brain which is what you will run your rca's out of(front, rear, sub, etc.). If you don't have the brain then you are fcuked as that deck will not work without the brain.
jonesbrooklyn is offline  
Reply With Quote
Old 02-21-2010, 11:54 PM
  #5  
Level 3 Supporter
iTrader: (17)
 
Father Yuli's Avatar
 
Join Date: Oct 2000
Posts: 11,606
ohhhhhhh so this is where my deck went?????
Father Yuli is offline  
Reply With Quote
Old 02-22-2010, 08:37 AM
  #6  
50 Watt CAFz'r
Thread Starter
iTrader: (4)
 
Mahna Mahna's Avatar
 
Join Date: Feb 2008
Posts: 495
Thanks for the help.....I'll let him know he is going to need some parts.
Mahna Mahna is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Sinemeup
General Discussion
0
11-29-2007 02:52 AM
The Tortoise
General Discussion
6
07-03-2007 08:19 PM
Blu
General Discussion
8
12-18-2005 10:15 AM


Thread Tools
Search this Thread