General Discussion General discussion about all things car audio, from pioneer, orion, alpine and eclipse.

Need help getting everything Set Up

Old 12-18-2012, 10:13 PM
  #1  
0 Watt CAFz'r
Thread Starter
 
Join Date: Dec 2012
Posts: 1
Need help getting everything Set Up

So first off, Im a car guy, I have 1996 Integra LS with plenty of mods and I track it often and drive it daily to. I bought it recently and it came with a Rockford Fosgate P4004 Amp, Front and rear Boston speakers, only the rear ones have tweeters and no headunit or face, I put in my Pioneer headunit and face from my old car into this one and wired everything to the amp minus the 4 wires required to run the headunit. I play music from my Mp3 player through a cheapo Aux chord. Not sure how well everythings working. Problems are as follows: Front speakers barely make any noise, sound isint great, if it gets too loud according to the amp, which isint very loud, the amp cuts out, I think its like a "protection zone" or something, I was also given a 10 inch Rockford Fosgate Hx2 Punch 100w sub without a box which I have yet to wire. I want to go bigger with subs tho and get front speakers working and better sound. Any ideas?
Swerve is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Calgarytrev
Install related
11
04-15-2011 08:59 PM
Njord
General Discussion
6
08-10-2009 12:19 PM
Canadain 2.5RS
General Discussion
16
07-06-2009 11:51 PM
Ijaz
General Discussion
0
06-28-2007 09:39 PM
Audio Aim
Canadian General Car Audio Discussion
11
08-06-2006 11:53 AM


Thread Tools
Search this Thread
Quick Reply: Need help getting everything Set Up


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.