General Discussion General discussion about all things car audio, from pioneer, orion, alpine and eclipse.

Need help installing my new system

Old 03-21-2009, 04:08 PM
  #1  
50 Watt CAFz'r
Thread Starter
iTrader: (1)
 
Join Date: Nov 2006
Posts: 271
Need help installing my new system

I've got a Rockford Fosgate 501BD and a JBL CS 60.4. I had it wired with #4 power wire in my last car with no troubles but I have a feeling it should have been something bigger. I'm thinking I should have #2, what do you guys think?
smith is offline  
Old 03-21-2009, 04:46 PM
  #2  
0 Watt CAFz'r
 
Join Date: Jan 2009
Posts: 28
You will be fine with some 4ga OFC
Wendel17 is offline  
Old 03-22-2009, 02:02 PM
  #3  
500 Watt CAFz'r
iTrader: (5)
 
420guy's Avatar
 
Join Date: Jul 2008
Posts: 975
You only have a 90amp (RF=50 & JBL=40) draw so 4ga (good for up to 125a)will be more than enough. Just make sure you have a 100amp fuse near the battery and you are good to go. Do you have the Rockford fused as it says it is 50a fused externally? Not 100% sure on this but I believe you need a 50amp fuse right before the power wire goes into it. If you have a fused distro that would work.
HTH
Nick
420guy is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
becskei
General Discussion
13
02-14-2010 12:49 AM
rvpr4
Install related
4
06-05-2009 02:40 PM
SUPERCHARGER
General Discussion
3
01-22-2009 05:48 PM
Blinddemonz
Install related
5
11-17-2006 07:13 PM
Vadim
Install related
16
08-08-2006 04:57 AM


Thread Tools
Search this Thread
Quick Reply: Need help installing my new system


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.