General Discussion General discussion about all things car audio, from pioneer, orion, alpine and eclipse.

battery dying

Old 01-27-2007, 09:40 PM
  #1  
50 Watt CAFz'r
Thread Starter
iTrader: (1)
 
DruidB's Avatar
 
Join Date: Jan 2007
Posts: 57
battery dying

I have a 2003 saturn Ion.. had my JVC DVD deck installed about a month ago... since then my batt has died 2 times... i boost it... let it run and its fine for a few days then dead again... seems to be dead after sitting for a day or two... now the deck functions fine...however it will not power up when i turn the key to accesory... it has to be "ON" did they **** up my install?
DruidB is offline  
Old 01-27-2007, 09:46 PM
  #2  
4000 Watt CAFz'r
iTrader: (5)
 
Join Date: Jan 2005
Posts: 4,643
two things your battery is about 4-5yrs old (i would look at a new one)
can you fined why the battery died the 1st time .it may have nothing to do with you install .
your battery may not hold the power to run the deck and amps when the car is not running
zzzzzzz is offline  
Old 01-27-2007, 09:48 PM
  #3  
50 Watt CAFz'r
Thread Starter
iTrader: (1)
 
DruidB's Avatar
 
Join Date: Jan 2007
Posts: 57
Originally Posted by zzzzzzz
two things your battery is about 4-5yrs old (i would look at a new one)
can you fined why the battery died the 1st time .it may have nothing to do with you install .
your battery may not hold the power to run the deck and amps when the car is not running

i have no amps or anything installed yet but the deck...
also i headlight died the same day that the batt went the first time
DruidB is offline  
Old 01-27-2007, 09:51 PM
  #4  
4000 Watt CAFz'r
iTrader: (5)
 
Join Date: Jan 2005
Posts: 4,643
start looking why headlight died the same day that the batt went the first time
zzzzzzz is offline  
Old 01-27-2007, 09:54 PM
  #5  
50 Watt CAFz'r
Thread Starter
iTrader: (1)
 
DruidB's Avatar
 
Join Date: Jan 2007
Posts: 57
but shouldnt the deck work on accesory? everything else does without sign of a power loss
DruidB is offline  
Old 01-27-2007, 11:37 PM
  #6  
4000 Watt CAFz'r
iTrader: (5)
 
Join Date: Jan 2005
Posts: 4,643
how did you wire up the deck ?
zzzzzzz is offline  
Old 01-27-2007, 11:38 PM
  #7  
50 Watt CAFz'r
Thread Starter
iTrader: (1)
 
DruidB's Avatar
 
Join Date: Jan 2007
Posts: 57
i didnt... i had it installed
DruidB is offline  
Old 01-27-2007, 11:42 PM
  #8  
4000 Watt CAFz'r
iTrader: (5)
 
Join Date: Jan 2005
Posts: 4,643
what does the shop say about it ?
zzzzzzz is offline  
Old 01-27-2007, 11:43 PM
  #9  
50 Watt CAFz'r
Thread Starter
iTrader: (1)
 
DruidB's Avatar
 
Join Date: Jan 2007
Posts: 57
im going in on tuesday.. i just wanted some opinions before i go in there
DruidB is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
MHarrisEP
General Discussion
6
06-19-2009 07:23 PM
Promasta
Car Audio Technical Discussions
10
04-11-2007 11:45 PM
Tormentor098
Car Audio Technical Discussions
8
03-18-2007 02:01 PM
aky
General Discussion
13
01-25-2007 06:41 PM
Sterling
General Discussion
30
03-14-2004 12:44 AM


Thread Tools
Search this Thread
Quick Reply: battery dying


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.