General Discussion General discussion about all things car audio, from pioneer, orion, alpine and eclipse.

Kenwood KDC shuts off...

Old 04-08-2008, 08:09 PM
  #1  
0 Watt CAFz'r
Thread Starter
 
Join Date: Apr 2008
Posts: 4
Kenwood KDC shuts off...

So i just got this deck from a friend. I have an 1988 Chrysler daytona CS. Its a kenwood KDC. It shuts of randomly usually, doesn't matter how loud it is. Sometimes it will turn off as soon as the cd starts playing, or it will wait for a few minutes. Any ideas? Oh and i have a pioneer amp.

Mike
luedemann is offline  
Old 04-08-2008, 09:47 PM
  #2  
500 Watt CAFz'r
iTrader: (3)
 
LOWTONEZ's Avatar
 
Join Date: Apr 2007
Posts: 872
Scrap it
LOWTONEZ is offline  
Old 04-09-2008, 12:34 AM
  #3  
0 Watt CAFz'r
Thread Starter
 
Join Date: Apr 2008
Posts: 4
Thanks?....

Mike
luedemann is offline  
Old 04-11-2008, 12:26 AM
  #4  
0 Watt CAFz'r
Thread Starter
 
Join Date: Apr 2008
Posts: 4
So i got a little more info for you. My exact deck is a KDC MP 528. Does it need power to eject the cd? Cause it always has power for that. But whenever it is just about to start playing a song, it will get maybe a quarter of a second out, then the deck will shut off. I've heard this deck has a built in amp? Would me having my pioneer deck hooked up cause this?

Mike
luedemann is offline  
Old 04-11-2008, 02:15 AM
  #5  
500 Watt CAFz'r
iTrader: (3)
 
LOWTONEZ's Avatar
 
Join Date: Apr 2007
Posts: 872
That deck is newer then my Kenwood unit. You shouldnt be having problems like that with it. And you mean you have an amp hooked up. And no it wouldnt have anything to do with it. Are you getting any error codes when it happens or does it just shut off?

Last edited by LOWTONEZ; 04-11-2008 at 02:23 AM.
LOWTONEZ is offline  
Old 04-11-2008, 02:30 AM
  #6  
500 Watt CAFz'r
iTrader: (3)
 
LOWTONEZ's Avatar
 
Join Date: Apr 2007
Posts: 872
You are going to have to check all of the wiring behind the deck and make sure it is not touching each other or metal of the car. Then check the fuse behind the deck and if it is hooked up to the fuse panel of your car also check that fuse too. If all is well and you still have the problem you need to get the unit serviced or replace it.
LOWTONEZ is offline  
Old 04-11-2008, 09:35 AM
  #7  
0 Watt CAFz'r
Thread Starter
 
Join Date: Apr 2008
Posts: 4
No error codes. But i have some questions. It only works when i connect the red and yellow wire from the deck, to the red wire from the car harness. Does this make sense?

Mike
luedemann is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Shazzamy
General SQ
3
09-13-2011 09:35 PM
Gen.Ben
Install related
7
04-16-2011 10:30 AM
mrchippy
General Discussion
1
01-09-2008 07:43 PM
JL_sunfire
General Discussion
17
09-24-2006 06:58 PM


Thread Tools
Search this Thread
Quick Reply: Kenwood KDC shuts off...


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.