General Discussion General discussion about all things car audio, from pioneer, orion, alpine and eclipse.

Problem with Kenwood CD Changer

Old 05-05-2006, 10:52 PM
  #1  
0 Watt CAFz'r
Thread Starter
 
Join Date: Aug 2004
Posts: 19
Problem with Kenwood CD Changer

Hi,

I have an older Kenwood head unit CA503 (I think is the model) with a 6 disk cd changer. Just the past week or so, I have been having trouble with the changer, but I do not know if the problem is with the actual headunit or the changer itself.

The head unit displays "CH NO". I turn off and turn on the HU and it was okay. A couple of days after that, it happened again, I tried turning off and turning but this time it did not work, even after several attempts. I then unpluged the changer and that fixed the problem for only that time. Now for the past 2 days the same is happening, and no matter what I do, it will not play CD anymore (Even after mamy tries to turn off/on and unplugging the changer).

Help!! Any ideas what CH NO means???? Is my changer broken? Will a new model Kenwood changer work with my older HU?


Thanks.

Kel
91cb7 is offline  
Old 05-06-2006, 03:22 AM
  #2  
50 Watt CAFz'r
 
Reekor's Avatar
 
Join Date: Apr 2006
Posts: 151
"CH NO" means that the head unit is not detecting the cd changer. 90% of the time this problem is due to a broken solder joint between the head unit's mainboard and the changer plug.


Originally Posted by 91cb7
Hi,

I have an older Kenwood head unit CA503 (I think is the model) with a 6 disk cd changer. Just the past week or so, I have been having trouble with the changer, but I do not know if the problem is with the actual headunit or the changer itself.

The head unit displays "CH NO". I turn off and turn on the HU and it was okay. A couple of days after that, it happened again, I tried turning off and turning but this time it did not work, even after several attempts. I then unpluged the changer and that fixed the problem for only that time. Now for the past 2 days the same is happening, and no matter what I do, it will not play CD anymore (Even after mamy tries to turn off/on and unplugging the changer).

Help!! Any ideas what CH NO means???? Is my changer broken? Will a new model Kenwood changer work with my older HU?


Thanks.

Kel
Reekor is offline  
Old 05-09-2006, 07:57 PM
  #3  
0 Watt CAFz'r
Thread Starter
 
Join Date: Aug 2004
Posts: 19
Just an update. I went to a shop and they said that most likely it is the laser on the changer. To repair the laser would cost around $150. I asked how much for a new changer and was quoted $200.00. So I bought a new changer, but I just found out that it is actually just the cable.

I hope they will let me return the changer and I can just buy the cable!!

Kel
91cb7 is offline  
Old 05-09-2006, 08:00 PM
  #4  
50 Watt CAFz'r
 
Reekor's Avatar
 
Join Date: Apr 2006
Posts: 151
Just make sure it's the cable and not the plug at the back of the head unit.

Originally Posted by 91cb7
Just an update. I went to a shop and they said that most likely it is the laser on the changer. To repair the laser would cost around $150. I asked how much for a new changer and was quoted $200.00. So I bought a new changer, but I just found out that it is actually just the cable.

I hope they will let me return the changer and I can just buy the cable!!

Kel
Reekor is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
vip3r87
Car Audio Technical Discussions
6
12-03-2006 07:17 PM
GrizZz
Install related
3
09-09-2005 01:14 PM
DrLecter
General Discussion
12
01-19-2005 08:09 PM
davis
General Discussion
1
09-10-2003 08:09 PM


Thread Tools
Search this Thread
Quick Reply: Problem with Kenwood CD Changer


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.