General Discussion General discussion about all things car audio, from pioneer, orion, alpine and eclipse.

Crackling sound through the speakers

Old 11-23-2007, 11:27 AM
  #1  
0 Watt CAFz'r
Thread Starter
 
Join Date: Aug 2007
Posts: 20
Crackling sound through the speakers

Hello, this morning, about half way through my drive to work, a crackling sound started coming from my speakers. I quickly turned off the stereo for fear that it could damage them somehow (I just bought them), but the sound persisted. I pulled over and the sound only stopped when the car was at a complete standstill. When I started moving again the noise started again as well. I ended up disconnecting the spade terminals from my speakers to stop the noise.

What could be causing this sound? Is my deck blown? I haven't had time to debug because I was on my way to work... If the deck isn't blow, could it be a wiring short somewhere? Has anyone encountered anything similar to this?

Thanks in advance...
kstich is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Haz Anga
Car Audio Technical Discussions
16
04-25-2010 02:48 PM
ported
General Discussion
7
01-14-2007 11:44 AM
iDs748
Install related
9
08-31-2006 06:06 PM
dan
Install related
2
12-27-2004 08:26 PM
Hardcore Rock Superstar
General Discussion
5
10-15-2003 07:18 AM


Thread Tools
Search this Thread
Quick Reply: Crackling sound through the speakers


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.