General Discussion General discussion about all things car audio, from pioneer, orion, alpine and eclipse.

Dead FM reception

Old 01-07-2008, 03:12 PM
  #1  
0 Watt CAFz'r
Thread Starter
 
Join Date: Jan 2008
Posts: 2
Dead FM reception

Hi guys,

I have a Volvo S40 with its standard radio. The other day, all of sudden, the FM reception went dead. The AM reception is fine, the CD player plays fine, the cassette player is fine but there is nada on FM: no noise, no sounds even if I crank up the sound. The day after, I did get a bit of reception, albeit not claer for a minut eor so and then it wnetr dead again never to be heard of (three days ago).

Any idea what has caused the problem or how to solve it?

Thanks in advance.

Richard
Pomerol is offline  
Old 01-07-2008, 04:03 PM
  #2  
0 Watt CAFz'r
 
Join Date: Sep 2007
Posts: 39
That's a toughie, I'm not familiar with Volvo but it sounds like a possible antennae problem. When I installed an after market head unit into my civic, at first the reception was really bad. I found out that I had an amplified antennae (or something like that) that needed a constant 12v to run it, not a 12v trigger.

Anyway, I'm wondering if something is wrong with your amplified antennae(if you have one), maybe it's toast. How old is your car?
sharkman is offline  
Old 01-07-2008, 04:37 PM
  #3  
0 Watt CAFz'r
Thread Starter
 
Join Date: Jan 2008
Posts: 2
Dead FM reception

Originally Posted by sharkman View Post
That's a toughie, I'm not familiar with Volvo but it sounds like a possible antennae problem. When I installed an after market head unit into my civic, at first the reception was really bad. I found out that I had an amplified antennae (or something like that) that needed a constant 12v to run it, not a 12v trigger.

Anyway, I'm wondering if something is wrong with your amplified antennae(if you have one), maybe it's toast. How old is your car?
Hi Sharkman,

Thanks for your reply. My car is 6 years old. Is there any way I can test your idea of a faulty amplified antenna. Please baer with my total incompetence in the matter.

Cheers,

Richard
Pomerol is offline  
Old 01-07-2008, 05:02 PM
  #4  
4000 Watt CAFz'r
iTrader: (5)
 
Join Date: Jan 2005
Posts: 4,643
look at your fuses see if one is nfg
then look at the wire for the antennae
i think it is a fuse
zzzzzzz is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Schwinn
Car Audio Technical Discussions
10
07-12-2009 04:15 PM
phildownunder23
General Discussion
2
10-01-2007 10:12 PM
voided
General Discussion
6
06-13-2007 09:27 PM
ShonBesharah
Install related
11
03-10-2006 09:22 AM
satanshollow
Install related
2
04-03-2005 01:17 PM


Thread Tools
Search this Thread
Quick Reply: Dead FM reception


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.